[Solved] Diablo 1 monsters in Diablo 2

Post here about all aspects of D2 mod making whether it's information, problems or whatever. Please specify whether your post is relating to Classic D2 or the Expansion.

Moderator: Nizari

Post Reply
User avatar
Posts: 5
Joined: Wed May 27, 2020 7:33 pm

[Solved] Diablo 1 monsters in Diablo 2

Post by Ghaleon777 » Sat May 30, 2020 7:28 pm

So i am trying to use Ogodei´s Diablo 1 monster pack: viewtopic.php?f=6&t=63701
I edit each TXT file as needed, but as soon as i try to put the animdata.d2 file back to my d2exp.mpq the game crashes...

Tried EVERYTHING i could, but i fail everytime, even using version 1.10 of the game.
Its frustrating because i have been searching for something like this since ages, and now i cant make it work!

If anyone can help me with this, i would be eternally appreciated.

EDIT: yes, i am using -direct -txt mode, i am familiar with txt modding in Diablo 2 also.
The problem comes when editing the animdata.d2 file, adding the entries of the D1 monsters.
UPDATE: Using the MPQ editor "winmpq-v164" doesn´t crash the game anymore when i add the animdata.d2 back to the d2exp.mpq file. But the monster that appears is another one... I double checked all the txt files and there is no error. Just bad luck.
SOLVED: i needed to use the fixed 1.13c files! I got them thanks to this post: viewtopic.php?f=4&t=65199&p=500241#p500241

Post Reply

Return to “General Mod Making”